Sharing on Facebook

When I select one of my images and click Share and then click Facebook, only the link shows up and few people are motivated to click on a link without an image..... I am so frustrated by this as I do not want to have to upload all my images to Facebook!
«1

Comments

  • grhookphotogrhookphoto Pflugerville, TXMember Posts: 3
    edited May 2013
    When I select one of my images and click Share and then click Facebook, only the link shows up

    Hm. I just tried this, but I first shared on FB, where there was no thumbnail, then I copied the link and pasted into a new browser window (which went to the proper page), then I tried sharing again. The post came up correctly that time.

    I went through this exercise 3 times: once to repeat the above steps (using a different image) and again (using yet another image) where I tried to share twice, but did not view the page directly between attempts. In this case neither "share" was successful.

    I would conclude there is a problem of some sort.
  • photojenicphotojenic Member Posts: 11
    I have to agree that the share option seems a little unstable. Not sure why or what is occurring here, but my clients are struggling and I am frustrated too. The social aspect of Zen is my big bug bear at the moment.
  • GDMKGDMK Member Posts: 56
    Hmmm, have to agree there seems something awry with the facebook interface. I followed the instructions given on one of the marketing webinars and Zenfolio reported that the photos had been exported to facebook successfully - question is where on facebook? They certainly havent shown up on my page ?!?
  • ZenBrianZenBrian Administrator Posts: 1,689
    This can happen if Facebook does not cache all of the information. To fix a link so it does post the thumbnail when you share it, first run the link through the Facebook Debug link: https://developers.facebook.com/tools/debug

    This screenshot helps illustrate it from your Edit View perspective:
    image
    Thanks!

    Brian
    Zenfolio Support
    image


    Check out my site! www.bussierephoto.com
  • CatLadyCatLady Member Posts: 4
    This seems to be a very tedious method of sharing my work on my FB page
  • GDMKGDMK Member Posts: 56
    Thanks for the feedback. It does seem to be a bit of a runaround and not as straightforward as I would like. Is improved Facebook integration on the to-do list?

    thanks
    Gary
  • ZenBrianZenBrian Administrator Posts: 1,689
    Unfortunately this is all on the Facebook side, to do with changes they made to their caching system. There isn't anything we can do to force Facebook to cache things any differently.
    Thanks!

    Brian
    Zenfolio Support
    image


    Check out my site! www.bussierephoto.com
  • photojenicphotojenic Member Posts: 11
    ZenBrian - thanks for trying, but yeah sharing socially is kind of vital to a social photographer, pinterest, facebook etc - zenfolio could be so amazing, but these things are starting to hurt - SAVE ME!!! lol Or if that is too hard, just find a way and to work it for us ;)
  • Add me to wanting a solution to this.
  • Edwin KinuthiaEdwin Kinuthia Member Posts: 1
    Hey guys! Please check out my site at edwink.zenfolio.com. I know there are only three photos but i need to know whether i am worth the while. Please i need your comments and also buy if you like
  • Monroe PhotographyMonroe Photography Member Posts: 1
    Edwin, your comment is off topic. If you would like thoughts on your photos at least on the site feedback forum http://forums.zenfolio.com/discussion/comment/59608/
  • I have had this issue as well but have found the following work for me.
    I always "Get Short Link" and give it time to get the thumbnail.
    I think getting the Short Link helps in the process.
  • Yes, but as others have pointed out, the point is for clients to be able to easily share my photos on their timeline, including a thumbnail. I agree with photojenic.....this is a problem. If I'm not mistaken, I believe Path galleries have found a way to accomplish this. Add me to the list of people wanting a solution to this.
  • Sorry..."Pass", not "Path"......

    Yes, but as others have pointed out, the point is for clients to be able to easily share my photos on their timeline, including a thumbnail. I agree with photojenic.....this is a problem. If I'm not mistaken, I believe Path galleries have found a way to accomplish this. Add me to the list of people wanting a solution to this.

  • PaulgPaulg Member Posts: 28
    ZenBrian said:

    Unfortunately this is all on the Facebook side, to do with changes they made to their caching system. There isn't anything we can do to force Facebook to cache things any differently.

    I'm not sure why its all down to Facebook, other sites (such as Fine Art America) don't have this problem and still show the thumbnail when sharing.
    I only seem to have this trouble sometimes, a post I made on 15th June showed the thumbnail, but a post made yesterday and today didn't.
    Paul
  • cjpaulcjpaul Member Posts: 7
    I noticed today that if I share a photo via Facebook there is no thumbnail consistently. If I hit cancel and share again via Facebook (doing nothing else) it will have a thumbnail consistently. Sounds like there is more to this than just on Facebook's end.
  • Nicky JamesonNicky Jameson TorontoMember Posts: 107
    Hi, I don't think this is a Facebook fault at all. I can share from every other Photo site (I am on three others) EXCEPT Zenfolio. Why would the caching be different for only Zenfolio? When I share from Flickr It inserts the photo - at a reduced size but large enough to see, same from my other sites. Sharing from Zenfolio with "get shortlink" works but even then it only inserts the thumbnail and link - not the full size photo. This is a real shortcoming for Zenfolio users.

    Is anyone from Zenfolio looking at this to fix it? If so when?

    I think it's not enough to simply blame Facebook, anyone should be able to share photos via social media and Facebook is the top place where people do it.
  • PaulgPaulg Member Posts: 28
    imahawki said:

    I noticed today that if I share a photo via Facebook there is no thumbnail consistently. If I hit cancel and share again via Facebook (doing nothing else) it will have a thumbnail consistently. Sounds like there is more to this than just on Facebook's end.

    Just tried this, it does work but I found I have to do it 3 or 4 times before the image shows, a work-around but a pain in the rear.
    I think its time for someone from Zenfolio to make a bit of an effort here and get it sorted - if other gallery sites can do it why does the Zenfolio team get defeated so easily.
  • Kevin CoppalottiKevin Coppalotti Member Posts: 38
    I'm having this problem as well. like others have mentioned it needs to be easy for our clients to share on their facebook page. Just a simple click is all most people can handle. It has definitely resulted in a noticeable decline in site effectiveness since the loss of the thumbnail.
  • PaulgPaulg Member Posts: 28
    Just as an update, I've tried flickr, Artflakes, DeviantArt and Fine Art America, all the sites can share posts to Facebook with a thumbnail without any problem. How much longer are we going to have to wait for Zenfolio to get its act together and admit its their end and for them to do something about the problem. This is suppose to be a support forum so please lets have some support from Zenfolio before we all go elsewhere.
  • Kevin CoppalottiKevin Coppalotti Member Posts: 38
    Just tested smugmug, the thumbnail works perfectly with them
  • PaulgPaulg Member Posts: 28
    I've contacted support directly about this problem and pointed them to this thread. We **may** get some sort of answer from them - but don't hold your breath
  • PaulgPaulg Member Posts: 28
    Well this is the answer I got back from support:

    Hi Paul,
    Thank you for contacting Zenfolio.

    It is in fact my understanding that Facebook has made changes which are impacting links posted on Facebook.

    A quick search of Facebook’s own help community also suggests this is not isolated to just Zenfolio sites:

    https://www.facebook.com/help/community/question/?id=10200708365214182

    Our developers do understand the importance of Facebook as a tool for sharing images and galleries from Zenfolio sites, and are looking into ways we can adjust to the changes Facebook has (and continues to make) to how their site operates. The debug solution that ZenBrian does work in the majority of cases, although we do understand this is an extra step, so we are continuing to search for other solutions.

    Please let me know if you have additional questions.


    Not much further on, in my reply to this I did suggest they post on this forum to keep everyone up to date - we shall see.
  • Nicky JamesonNicky Jameson TorontoMember Posts: 107
    Perhaps Zenfolio can look at the metadata that SmugMug, 500px, Flickr, Deviant Art and seemingly all the other Photosites are using and emulate it to fix this issue once and for all. How long are ZF developers going to be looking into it? The issue posted on the FB community site is over 4 months old. The only place I cannot post to Facebook from is Zenfolio. I don't understand how I can post full size images by using the Share to Facebook button/link on Flickr, yet cannot do it here. I also don't understand why Zenfolio doesn't take advantage of Facebook Open Graph as CMSs like Wordpress are able to. And by the way Flickr has been able to post to Facebook throughout all the Facebook changes. Please make this a priority to fix.
  • Patrick VisserPatrick Visser Member Posts: 1
    This should be fixed, it is a problem that i have happen.
    I can use the workaround.
    But Clients that share a photo don't know how, so they only share a link and no photo shows up :(
  • Kevin CoppalottiKevin Coppalotti Member Posts: 38
    has this problem been fixed? I just saw one of my clients share on facebook and the thumbnail is showing. ^:)^
  • Kevin CoppalottiKevin Coppalotti Member Posts: 38
    Just saw another thumbnail in a share. Problem looks fixed. Can anyone else confirm or am i just lucky?
  • Kevin CoppalottiKevin Coppalotti Member Posts: 38
    Looks like it is not fixed. doh! Had to run the link thru the facebook debugger to get it work for me just now :(
  • My client only wanted to share certain images.. so I directed them at the favorites feature of the gallery..

    unfortunately when shared.. no preview.. defeats the purpose.. disappointing.
  • ryansbryansb Member Posts: 2

    I have had this issue as well but have found the following work for me.
    I always "Get Short Link" and give it time to get the thumbnail.
    I think getting the Short Link helps in the process.

    Thanks @'Fab Photos glamour photography in Port Macquarie'

    This has also worked for me - only twice but so far so good.

    http://ryansb.zenfolio.com/
Sign In or Register to comment.
Help test new Zenfolio features by applying to become a Beta Tester. More info here.
Join our live streaming Zenfolio Customer Support Q & A session on You Tube!

Thursday's at 2pm EST 11am PST

NOTE: You can sign in using your Zenfolio account! To link both accounts, make sure both email addresses match before signing in.
If you have a new feature idea that you think would be a great addition to the Zenfolio service please submit it to our feature voting system.