Edge browser crashing repeatedly using Zenfolio as of the last few days.

This morning had at least 5+ instances of "zenfolio.com is not responding" browser then restarts and I can then continue.

This occurs when in the gallery edit view and I am arranging folders, uploads and galleries.

Am using MS Edge browser in Windows 10 64 bit.


Comments

  • Shooting-StarsShooting-Stars Member Posts: 2
    I have a similar problem. I wonder how many customers have a similar problem?
  • ChessZenChessZen Administrator Posts: 465
    We haven't seen any issue with zenfolio.com not responding today.

    Also we haven't received a similar report from any other photographers.

    If the was an issue on our end that has caused zenfolio.com to not respond, we would have received a deluge of messages from photographers reporting an issue.

    If you're still experiencing the issue, we recommend trying to visit zenfolio.com using a different web browser. That will help to determine if the issue is caused by the browser.

    If the issue persists, contact Zenfolio support and let us know.

    Also just to add... to work with your account and make changes through the Dashboard, you'll need to use a supported desktop/laptop web browser. Unfortunately, the Edge browser is not yet a supported web browser and so not all processes will work when using that browser.

    Click here for a list of the supported web browsers.
Sign In or Register to comment.
Help test new Zenfolio features by applying to become a Beta Tester. More info here.
Join our live streaming Zenfolio Customer Support Q & A session on You Tube!

Thursday's at 2pm EST 11am PST

NOTE: You can sign in using your Zenfolio account! To link both accounts, make sure both email addresses match before signing in.
If you have a new feature idea that you think would be a great addition to the Zenfolio service please submit it to our feature voting system.