My custom URL links don't work anymore.

I've been a Zenfolio user for years. I have my own domain: BillYoungImage.com through GoDaddy that redirects to my Zenfolio account https://youngphotography1886.zenfolio.com/ . Obviously I like using BillYoungImage.com more than the Zenfolio created one. In the past, when I created a gallery for a client I would go to the Sharing and client access tab and create a name for their gallery. For example "wallart" Then I could give them my URL/friendly URL (ie: billyoungimage.com/wallart and it would take them to their gallery. Now, (after the Https migration I think) this process doesn't work and it only takes them to my main page. In order for the friendly URL to work I have to use the annoyingly long youngphotography1886.zenfolio.com prefix and then the /wallart . This is very annoying, and several of my clients no longer have access to their galleries with my business URL.

Anybody have any ideas on how I can fix this?

Comments

  • To fix that, point BillYoungImage.com to Zenfolio using DNS records and disable the forwarding.

    Click here for how to point the domain to Zenfolio.

    After doing that, you can use the Friendly URL feature to give your galleries a friendly URL.

    So for example, you can give the gallery a friendly URL of billyoungimage.com/wallart instead of using its default web address that consisted of the letter and then some numbers.

    Click here of how to use the friendly URL feature.
Sign In or Register to comment.