Home Uploading and Organizing Your Photos and Videos

Need Immediate Answers? Check out our SUPPORT CENTER or CONTACT OUR SUPPORT TEAM

Jeffrey Friedl's Lightroom plugin not working

I've used this plugin for years, and today it won't upload, giving me an error "unexpected reply from Zenfolio". I found numerous forums referring to upload issues in the past, but nothing lately. I have Lightroom and the plugin updated and a few images uploaded before it started doing this. I have contacted Jeffery, but from what I'm reading, this is a ZENFOLIO problem.

If you can't fix this issue I will have to switch to another service. If I can't get my photos to Zenfolio, there is no point. I've been a long time customer, but from what I see you have serious ongoing issues with this plugin. If you're not going to put the effort into creating your own plugin to connect with the most popular image management program on the planet, you need to at least make sure your service works with the one and only plugin available that you yourself refer people to.


  • Sorry to hear that you're experiencing an issue with Jeffrey's Plugin. I tested it just now but I am able to export photos to Zenfolio using the plug in without any issues.

    So in this case, please contact Jeffrey and let him know that you're experiencing an issue with his plugin.

    You can find his support page for the Lightroom plugin here.

    I do just want to note that even if the issue is due to something in Zenfolio's end, we do still need to work with the plugin's creator to resolve the issue. So by contacting Jeffrey, he will be able to troubleshoot the issue. And if it does require some changes on our end, he will be able to work with our engineers to resolve the issue.
  • Yep, I am getting the same issues only started today. i have clients waiting for their images.

    jeffery said it is a Zenfolio's issue and that zenfolio knows about it and refuses to don't anything about it.

    I need this fixed. I don't want to have to send contacts over to the client, or find an other program that will do it.

  • I am also having issues with the plug-in. Sometimes 1 or sometimes as many as 20 will upload until it stops. I did what someone else suggested - I used Jeffery's plug-in to export images to a temporary folder on my desktop which basically converted my RAW files to jpegs. Then I used the manual upload method to Zenfolio - drag and drop from my temp folder to the destination folder on Zenfolio. They did upload fairly quickly - like when the plug-in actually worked. But I noticed that on several occasions during the upload a message would appear that would say something like 'connection to server lost'...but would restart the uploads automatically after connection with Zen was reestablished. I am thinking that Jeffrey's plug-in does not have a auto-connect feature. Ultimately though, it appears that the Zen servers are dropping connections. So for now, it appears I have a workaround but it is rather untimely and fairly labor intensive. I do see that Zenfolio has it's own LR plugin so maybe I can try that until Zen and Jeffrey get things worked out.
  • AllisonZenAllisonZen Administrator Posts: 238
    Our developers are looking into this error when importing images into Zenfolio from the Jeffrey Friedl Lightroom Plug-in!

    I will provide an update once we have more information to share!
  • Kingdom Works MediaKingdom Works Media Member Posts: 2
    Same issue here. Been happening pretty consistently since around the time the New "PhotoPage" was introduced.
  • Finchley ThompsonFinchley Thompson Member Posts: 16
    I had this issue as well. After some back and forth with Zen denying it was their problem and blaming Jeffrey it seems that it was a server issue at their end. A friend of mine who uses Zenfolio got an apology email. I hope they sent one to Jeffrey Friedl as well.
  • Is there any solution available? I'm always getting network time-out replies after uploading some pictures via plugins from Lightroom. After uploading several pictures the process is canceled and after a while I'm getting the error message (time-out, see attachement). I have a very fast Internet connection (100 mbit). It's happening with both plugins (Jeffrey Friedl and New P Products). I have tried it out with 2 computers (PC and Notebook). Always the same result! It seems to be a problem on the server side! Please help!
    Error Zenfolio, Lightroom plugin.jpg
    711 x 216 - 71K
  • What is being done about this I am experiencing the same "timedout" error
Sign In or Register to comment.