Home Uploading and Organizing Your Photos and Videos

Need Immediate Answers? Check out our SUPPORT CENTER or CONTACT OUR SUPPORT TEAM

Lightroom Plugin: Upload to Zenfolio not working


I have problems uploading from Lightroom to Zenfolio via the recommended plugins (Jeffrey Friedl, New P Products). After some pictures are uploaded the process is cancelled. After some further minutes an error message occurs (Timeout, network error). But my network connection is excellent (100 mbit up and down). I have already found similar problem reports in the Internet. It seems to be a problem on the server side. I have tried it out on several computers (PC and Notebook), always with the same result. I have tried out other plugins from Jeffrey Friedl for different providers (e.g. SmugMug). With these other plugins and other providers everything is working fine!! Only the Zenfolio plugins are not working. It doens't depend on the plugin provider (Jefferey Friedl or New P Products) as I'm getting similar error messages with all of them. Please give me and all affected other users some support and fix this problem! Thank you!

Best regards


  • In the meantime I did some further investigation. Also the upload via different browsers (Firefox, Chrome) is interrupted. For 10-20 photos it's working fine. But then it is stopped for some of the photos. After 5 photos can't be uploaded it's stopping in general. You have to restart the upload of the affected photos manually then it will continue. But this is not acceptable! Sorry! Please fix this upload issue! I recognized that other users had similar problems but didn't receive a solution for months! I hope this will change soon!
Sign In or Register to comment.